
2. APPLICABLE TO COMMERCE AND MANAGEMENT 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

 

Course Objectives: 

1. Provide a foundation in the AI ecosystem, including hardware, cloud, and edge platforms 

relevant to commerce and management. 

2. Familiarize students with different types of datasets and public repositories used in AI 

research. 

3. Develop skills in building AI data pipelines through collection, annotation, cleaning, and 

preprocessing. 

4. Understand how AI enhances retail and e-commerce and explore personalization, 

recommendation systems, and customer engagement 

5. Apply AI to streamline business processes and decision-making and explore AI in finance, 

HR, and supply chain management 

Course Outcomes: 

On successful completion of this course, students will be able to: 

1. Explain the AI ecosystem (hardware, cloud, and edge devices) and its relevance to 

commerce and management. 

2. Differentiate between structured and unstructured data, and utilize public datasets for 

business-oriented AI applications. 

3. Design a conceptual AI data pipeline for solving real-world problems in commerce and 

management. 

4. Understand and apply AI technologies to improve customer engagement and 

personalization in commerce. 

5. Use AI tools to streamline business operations, enhance decision-making, and detect 

patterns in data. 

 

 



Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 

Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 



Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 

Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER) 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

 

Unit 4: AI in Commerce – Transforming the Consumer Experience 

Introduction to AI in Commerce, Recommendation Engines (Collaborative & Content-Based), 

Chatbots and Virtual Assistants, Sentiment Analysis and Review Mining, Inventory Optimization 

and Demand Forecasting, Ethical Issues related to use of AI in Commerce and Business: Bias, 

Privacy, and Transparency 

 

Unit 5: AI in Business Operations – Driving Efficiency and Insight 

AI in Business Intelligence and Predictive Analytics, Financial Applications: Fraud Detection, 

Risk Modelling, HR Applications: Resume Screening, Employee Analytics, Supply Chain 

Automation and Optimization, AI in Marketing: Customer Segmentation, Lead Scoring, Strategic 

Adoption of AI in Enterprises, Explainable AI in E-Commerce. 

 

  

 

 

 

 



2. APPLICABLE TO COMMERCE AND MANAGEMENT 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practical                                             Credits: 1                                          2 hrs/week  

 

Suggested Lab Practicals (No Coding) 

Lab 1 - Exploring Public Datasets (Orange Data Mining) 

● Visit a public repository (Kaggle, UCI, data.gov.in) 

● Download a dataset (e.g., rainfall data, literacy rates, or traffic accident statistics) 

● Procedure: 

1. Open Orange → Add File widget → Load a CSV (e.g., Titanic dataset). 

2. Connect to Data Table → View rows/columns. 

3. Connect to Data Info → Check attributes, data types. 

4. View in Data Table and Distributions widget. 

● Observation: Note numeric, categorical, missing values. 

● Outcome: Students understand structured data format in CSV. 

  

Lab 2 - Understanding Dataset Metadata and Formats 

● Take two datasets in different formats (CSV, JSON) 

● View metadata (description, features, size, license) 

● Compare domain-specific datasets (e.g., medical vs. finance) 

  

Lab 3 - Data Annotation Exercise 

● Use MakeSense.ai or VGG Image Annotator (VIA) 

● Annotate 10 sample images (traffic signs, fruits, or medical scans) 

● Export annotations in XML or YOLO format 

● Discuss annotation errors and challenges 

  

 

 



Lab 4 - Data Cleaning and Visualization (Orange Data Mining) 

● Aim: To clean dirty data and visualize categorical and numeric attributes. 

● Procedure: 

1. Load dataset. 

2. Connect File → Edit Domain (to change types) and Impute (to fill missing values). 

3. Compare cleaned vs. original in Data Table. 

4. Distributions widget. 

5. Check various features distribution. 

(Optional: Create simple bar charts/line charts to visualize trends using Google Looker 

Studio) 

● Observation: Missing values filled with mean/median., Graphical representation of data. 

● Outcome: Learn importance of data cleaning., Students learn importance of visualization 

in preprocessing. 

  

Lab 5: Train/Test Split in Orange 

● Aim: To split dataset for AI training/testing. 

● Procedure: 

1. Load Titanic dataset. 

2. Connect File → Data Sampler (70% train, 30% test). 

3. Connect outputs to Data Table widgets to view. 

● Observation: Students see two different subsets. 

● Outcome: Concept of model validation using split data. 

 

Lab 6: Introduction to AI in Commerce – Use Case Exploration 

Prerequisite: Discuss conceptually about Clustering 

Objective: Understand how AI is applied in commerce through data visualization and clustering. 

Orange Workflow: Use Orange Data Mining Tool 

Widgets Used: File → Data Table → Scatter Plot → Hierarchical Clustering 

Dataset: Retail customer data (e.g., purchase frequency, amount spent) 

Dataset Link: Retail Sales Data 

Activities: 

https://www.kaggle.com/datasets/noir1112/retail-sales-data
https://www.kaggle.com/datasets/noir1112/retail-sales-data


·                Load customer data and visualize spending patterns. 

·                Apply clustering to identify customer segments. 

·                Discuss how businesses can tailor services to each segment. 

Outcome: Students grasp how AI helps businesses understand and target consumers more 

effectively. 

  

Lab 7: Recommendation Engine Simulation 

Prerequisite: Discuss conceptually about Clustering 

Objective: Simulate collaborative filtering using similarity-based clustering. 

Orange Workflow: 

Widgets Used: File → Distance → Hierarchical Clustering → Data Table 

Dataset: User-product ratings matrix 

Dataset Link: Amazon Product Recommendation System 

Activities: 

● Calculate similarity between users. 

● Group similar users and recommend products based on cluster behavior. 

● Discuss differences between collaborative and content-based filtering. 

Outcome: Students understand the logic behind recommendation systems and how they 

personalize user experience. 

  

Lab 8: Chatbot Intent Classification 

Prerequisite: Discuss conceptually about Linear Regression & Logistic Regression 

Objective: Train a model to classify customer queries into intents. 

Orange Workflow: 

Widgets Used: File → Preprocess Text → Bag of Words → Logistic Regression → Test & 

Score 

Dataset: Sample customer queries labeled with intents (e.g., “track order”, “return item”) 

Dataset Link: Customer Intent Classification 

Activities: 

● Preprocess and vectorize text data. 

● Train a classifier to predict query intent. 

https://www.kaggle.com/code/rushiekarteekchalla/amazon-product-recommendation-system
https://www.kaggle.com/code/rushiekarteekchalla/amazon-product-recommendation-system
https://www.kaggle.com/code/youssefm0stafa/customer-intent-classifacation
https://www.kaggle.com/code/youssefm0stafa/customer-intent-classifacation


● Evaluate accuracy and discuss chatbot training. 

Outcome: Students learn how AI understands and responds to customer queries. 

  

Lab 9: Sentiment Analysis of Reviews 

Prerequisite: Discuss conceptually about Naive Bayes 

Objective: Classify customer reviews as positive or negative. 

Orange Workflow: 

Widgets Used: File → Preprocess Text → Bag of Words → Naive Bayes → Test & Score 

Dataset: Product reviews with sentiment labels 

Dataset Link: Amazon Product Reviews – Sentiment Analysis 

Activities: 

● Clean and tokenize review text. 

● Train a sentiment classifier. 

● Visualize word clouds for positive vs. negative reviews. 

Outcome: Students analyze customer feedback and extract actionable insights. 

 

Lab 10: Demand Forecasting with Regression 

Prerequisite: Discuss conceptually about Linear Regression & Logistic Regression 

Objective: Predict future sales using regression models. 

Orange Workflow: 

Widgets Used: File → Linear Regression → Scatter Plot → Test & Score   

Dataset: Historical sales data (e.g., monthly sales, promotions) 

Dataset Link: Comprehensive Retail Sales Data 

Activities: 

● Train a regression model to forecast sales. 

● Visualize predictions vs. actuals. 

● Discuss implications for inventory planning. 

Outcome: Students understand how AI supports demand forecasting and inventory control. 

  

 

 

https://www.kaggle.com/datasets/miriamodeyianypeter/sentiment-analysis-amazon-product-reviews
https://www.kaggle.com/datasets/miriamodeyianypeter/sentiment-analysis-amazon-product-reviews
https://www.kaggle.com/datasets/shelendata/comprehensive-dataset-for-retail-data-analysis
https://www.kaggle.com/datasets/shelendata/comprehensive-dataset-for-retail-data-analysis


Lab 11: Bias Detection in AI Models 

Prerequisite: Discuss conceptually about Linear Regression, Logistic Regression & Confusion 

Matrix 

Objective: Explore bias in predictive models and its impact. 

Orange Workflow: 

Widgets Used: File → Logistic Regression → Confusion Matrix → Distributions  

Dataset: HR hiring data with gender or age attributes 

Dataset Link: HR Data Analytics 

Activities: 

● Train a model to predict hiring decisions. 

● Analyze performance across demographic groups. 

● Discuss fairness, transparency, and ethical implications. 

Outcome: Students critically assess bias and propose ethical safeguards. 

  

Lab 12: Predictive Analytics for Business Intelligence 

Prerequisite: Discuss conceptually about Random Forest 

Objective: Use classification to predict customer churn. 

Orange Workflow: 

Widgets Used: File → Random Forest → Test & Score → ROC Analysis 

Dataset: Telecom or subscription data with churn labels 

Dataset Link: Telco Customer Churn – IBM Dataset 

Activities: 

● Train and evaluate a churn prediction model. 

● Interpret ROC curves and accuracy. 

● Discuss how businesses can act on predictions. 

Outcome: Students apply predictive analytics to improve customer retention. 

  

Lab 13: AI in HR and Marketing – Resume Screening & Segmentation 

Prerequisite: Discuss conceptually about Clustering 

Objective: Classify resumes and segment customers using clustering. 

Orange Workflow: 

https://www.kaggle.com/datasets/samruddhi4040/hr-data-analytics
https://www.kaggle.com/datasets/samruddhi4040/hr-data-analytics
https://www.kaggle.com/datasets/yeanzc/telco-customer-churn-ibm-dataset
https://www.kaggle.com/datasets/yeanzc/telco-customer-churn-ibm-dataset


HR Task: File → Preprocess Text → Bag of Words → Logistic Regression 

Marketing Task: File → k-Means Clustering → Scatter Plot  

Resume Screening Dataset: Employee Hiring Data 

Customer Segmentation Dataset: Customer Segmentation Dataset 

Activities: 

● Screen resumes based on job fit. 

● Segment customers by behavior or demographics. 

● Discuss automation benefits and risks. 

Outcome: Students explore how AI enhances HR and marketing efficiency. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.kaggle.com/datasets/malsha/employee-hiring-data
https://www.kaggle.com/datasets/malsha/employee-hiring-data
https://www.kaggle.com/datasets/teddybrown414/customer-segmentation-dataset-from-a-company
https://www.kaggle.com/datasets/teddybrown414/customer-segmentation-dataset-from-a-company

